My issue list so far

brockdog12

Outer Banks
Well-Known Member
First Name
Bill
Joined
Apr 29, 2021
Messages
149
Reaction score
101
Location
NTX
Vehicle(s)
2021 Bronco Sport
These are the things my BS BB will be going in for soon, currently at 2100 miles after a month of ownership and may have to add some things. Some of these items may seem petty to some.

1. Windshield camera cover vibration
2. Blank instrument cluster display at times, no odometer, trip meter, miles to empty, etc. Only have tach and speedometer, nothing in between. Have to reset the vehicle several times to get it back.
3. Driver seat pops on lower left side on acceleration from a stop and when turning right
4. Rear wiper stops in odd spots sometimes and not always in normal off position.
5. Rear brake dragging noise when backing up in rain or humid weather...annoying since I'm in a high humidity area. May go away in time.
6. Vehicle does not sit level, lower on the drivers side, noticeable when parked level ground. Quick measurements made at fender wells shows to be off about 3/8”.
7. Left rear door sill plate trim not locked into to other sill trim piece, tab appears to be broken. Right side sill plate is fine.
8. Drivers window does not stay up all the way, falls a little after releasing switch allowing wind noise. This just started in the past week or so
Advertisement

 
Last edited:

Alfredo

Base
Well-Known Member
First Name
Alfredo
Joined
Apr 20, 2021
Messages
141
Reaction score
248
Location
33897
Vehicle(s)
2021 Ford bronco Sport
These are the things my BS BB will be going in for soon, currently at 2100 miles after a month of ownership and may have to add some things. Some of these items may seem petty to some.

1. Windshield camera cover vibration
2. Blank instrument cluster display at times, no odometer, trip meter, miles to empty, etc. Only have tach and speedometer, nothing in between. Have to reset the vehicle several times to get it back.
3. Driver seat pops on lower left side on acceleration from a stop and when turning right
4. Rear wiper stops in odd spots sometimes and not always in normal off position.
5. Rear brake dragging noise when backing up in rain or humid weather...annoying since I'm in a high humidity area. May go away in time.
6. Vehicle does not sit level, lower on the drivers side, noticeable when parked level ground. Quick measurements made at fender wells shows to be off about 3/8”.
Oh wow! I haven't hit a thousand miles on my BS yet, but I've noticed lots of heat coming from the top of the steering wheel column.
 
OP
OP
brockdog12

brockdog12

Outer Banks
Well-Known Member
First Name
Bill
Joined
Apr 29, 2021
Messages
149
Reaction score
101
Location
NTX
Vehicle(s)
2021 Bronco Sport
Oh wow! I haven't hit a thousand miles on my BS yet, but I've noticed lots of heat coming from the top of the steering wheel column.
I need to feel that while driving, mine be be warm too. Not something you’d typically check for.
 

johnardsg

Big Bend
Well-Known Member
First Name
johnard
Joined
May 10, 2021
Messages
193
Reaction score
138
Location
Oregon
Vehicle(s)
2021 BS BigBend/2011 v6 Rav4
Im going to add one here, if you have a hitch with a bike rack and then you reverse from a fresh start, the parking assist will keep on beeping until you go forward or press down then off (so many clicks) :headbang:
 

MarkyMark75

Big Bend
Member
Joined
May 8, 2021
Messages
10
Reaction score
32
Location
Auburn, GA
Vehicle(s)
2021 Bronco Sport BB
I’m at 2900 miles and on my third set of tires. First set all four were defective and couldn’t be balanced. Second set three of the four couldn’t be balanced and had sidewall defects. All the tires were the 225/65/17 Continentals that come with BigBend edition. Third set seem to be fine but the dealer ordered me Michelin tires instead.
 
OP
OP
brockdog12

brockdog12

Outer Banks
Well-Known Member
First Name
Bill
Joined
Apr 29, 2021
Messages
149
Reaction score
101
Location
NTX
Vehicle(s)
2021 Bronco Sport
I’m at 2900 miles and on my third set of tires. First set all four were defective and couldn’t be balanced. Second set three of the four couldn’t be balanced and had sidewall defects. All the tires were the 225/65/17 Continentals that come with BigBend edition. Third set seem to be fine but the dealer ordered me Michelin tires instead.
I can say I have Continentals and have had no issues with them so far.
 

LastBronco

Big Bend
Member
Joined
May 7, 2021
Messages
18
Reaction score
9
Location
Indiana
Vehicle(s)
2021 Bronco Sport
I’m at 2900 miles and on my third set of tires. First set all four were defective and couldn’t be balanced. Second set three of the four couldn’t be balanced and had sidewall defects. All the tires were the 225/65/17 Continentals that come with BigBend edition. Third set seem to be fine but the dealer ordered me Michelin tires instead.
My Big Bend came with Michelin's
 

13MikeH

Badlands
Well-Known Member
Joined
Mar 26, 2021
Messages
1,862
Reaction score
2,567
Location
Gone driving life is short
Vehicle(s)
Bronco sport
Im going to add one here, if you have a hitch with a bike rack and then you reverse from a fresh start, the parking assist will keep on beeping until you go forward or press down then off (so many clicks) :headbang:
huh...that's interesting. I've used a hitch rack a couple times, and other than being a small visual obstruction it hasn't set off any alerts or beeps. Maybe that's not a good thing on my end :) It's just crazy all the oddities across the board everyone is experiencing.
 

rdc17

Badlands
Well-Known Member
Joined
Dec 18, 2020
Messages
136
Reaction score
164
Location
VA
Vehicle(s)
Bronco Sport Badlands
Im going to add one here, if you have a hitch with a bike rack and then you reverse from a fresh start, the parking assist will keep on beeping until you go forward or press down then off (so many clicks) :headbang:
huh...that's interesting. I've used a hitch rack a couple times, and other than being a small visual obstruction it hasn't set off any alerts or beeps. Maybe that's not a good thing on my end :) It's just crazy all the oddities across the board everyone is experiencing.
The rear parking sensors get disabled when you hook up the trailer light connector. Surely someone makes some sort of plug in device that simulates the same electrical load to bypass this for trailer hitch attachments without lights?
 

13MikeH

Badlands
Well-Known Member
Joined
Mar 26, 2021
Messages
1,862
Reaction score
2,567
Location
Gone driving life is short
Vehicle(s)
Bronco sport
The rear parking sensors get disabled when you hook up the trailer light connector. Surely someone makes some sort of plug in device that simulates the same electrical load to bypass this for trailer hitch attachments without lights?
Well that's what's odd. It was just a bike rack, no lights connected. But I see your point
 
Advertisement

 
Advertisement
Top